N63 index #12 injectors leaking

image

Ok here it goes guys,,,,I guess I lied to some of you,,,,,the other day some of you saw and asked if I have seen the N63 index #12 injectors go bad,,,,and I said no I haven’t seen them go bad,,,,,,well guess what happened today at work,,,,lol,,,,,I had a 2010 750 N63 come in which the check engine light on,,,,the car has 58k miles on it,,,,,the car package was done in dec 2015,,,, and I found 3 injectors ad,,,,,I found 3 spark plugs fuel soaked,,,,,so I guess i have to correct myself and say,,,,,yes I have seen the newest injectors go bad,,,,thank goodness they are still cover under the emissions warranty 7/70

image

This entry was posted in Uncategorized and tagged , . Bookmark the permalink.

14 Responses to N63 index #12 injectors leaking

  1. Pawel says:

    Is #12 still the latest index? I’m about to have all 8 replaced in my car as a part of the CCP (for some odd reason it’s very unpopular in Europe) and this looks kinda scary.

    Like

  2. Pawel says:

    When was the first time you saw #12 injectors being available? I’m trying to find out when did BMW release them. I’m trying to find some information regarding history of my friend’s car. In one bank there are 3x #12 and 1x #11. We are trying to find out when did the previous owner of his 7er replace the injectors (for cars sold on the European market, BMW doesn’t cover the costs of CCP if you are out of warranty, so he had to do it by himself – that’s probably why he did it in only one bank – in the other one there are 4x #9 and will be replaced asap).
    Thank you!

    Like

    • I don’t remember the first time I saw #12 index injectors,,,,that sucks that who ever it was didn’t replace all the injector to index #12 all at the same time,,,BMW knew there was a problem with the lower index injectors,,,can you get me the last 7 digits of the VIN numbers,,,,,maybe I can run a DCS report on the car for you

      Like

  3. Eddy says:

    what codes did it throw?

    Like

  4. Ryan Mindemann says:

    Trying to diagnose a fuel smell while driving and idling parked. I have inspected my injectors to make sure they weren’t leaking externally. N63 index 12 injectors. All metal fuel lines are tight and verified. What else could be causing this smell? I have several hours into diagnosis and can’t find any visible leaks. Any suggestions?

    Like

    • Did you check on the driver side the foot long rubber fuel feed line will start to weep fuel

      Like

      • Ryan Mindemann says:

        Wouldn’t it some sort of noticeable drip or moisture on it? Appears to be dry.

        Like

      • Ok ,,,,do you smell the fuel inside the engine compartment or outside the car,,,,sometimes you just have to follow your nose and follow the fuel smell if you can.

        Like

      • Ryan Mindemann says:

        There is fuel smell on the outside and sometimes inside. Definitely seems stronger on the driver’s side. It comes and goes a bit- some days it’s really strong others not so much. I’ve tried using my nose but that’s as close as I can get.

        Is there anything with that solenoid attached on the drivers side intercooler or with the hard plastic piping that could cause it? Otherwise I might take a chance and order that rubber fuel line.

        Like

      • I would start with that rubber hose,,,,that should be the cheapest and easy to replace

        Like

      • Ryan Mindemann says:

        I’ll do it and report back. 🙂 Thanks for the help!

        Like

  5. Ryan says:

    I replaced that fuel hose as you prescribed and the smell is gone! The old hose itself appears to be fine, but must not be. The new hose is installed and no smell now for a week. Thanks for the help!

    I have another small problem. for the last couple years, everyone once in a while on a warm start, the engine will not idle properly. It will start then wildly fluctuate idle between 1000RPM and maybe 250 or less. It only does it on a warm start and only immediately after the vehicle is put into gear. Never has happened in “Park” This used to happen every couple months but now it’s a couple times a week. When this happens (again only when put into gear D or R) the vehicle will lurch ahead or attempt to and will either stall or settle down in about a couple seconds. Sometimes I can get it into park or neutral and it settles down, other times I’m trying to make sure I don’t hit a parked car and it dies. Restart engine everything is fine.

    No CEL, new spark plugs, no stored codes.

    Any ideas?

    Like

    • Glad fuel smell is gone,,,,sorry no real idea on that problem,,,,it could be a ignition coil or maybe a vanos solenoid or vanos units,,,,it’s really hard to say without a check engine light coming on.

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.