N55 blow off valve

image This is a good one,,,we don’t see this to often,,,,F10 2012 N55 engine,,,,check engine light came on 1 time only,,,,fault was turbo over boost,,,,happen at 2600 rpms,,,,,we already replaced the electric pressure control valve which sits next to the valve cover,,,,I performed the turbo boost test,,,,passed test,,,,I smoke tested the turbo and intake system,,,no leak,,,,if there was a leak I would have a low boost fault.image I checked the wastewater,,,waste gate is vacuum controlled,,,I checked the waste gate with a vacuum pump,,,,,waste gate working ok,,,,this picture is the electronic blow off valve,,,,we were thinking the blow off valve was hanging up,,,causing the over boost fault.image Replacing the blow off valve wasn’t to hard,,,,you just remove the water pump and you have easy access to the blow off valve,,,,just 3 Allen head bolt hold it into place.,,,,this took care of the problem.

This entry was posted in Uncategorized and tagged , , , , . Bookmark the permalink.

19 Responses to N55 blow off valve

  1. Faizel Latief says:

    Hi,
    I have a 2010 F10 535i (N55) and it came up with Drivertrain warning and went into limp mode. This happens almost every time and not necessarily under heavy acceleration…even when cruising.
    BMW ran diagnostics and kept getting these errors:
    “Charging pressure control, plausibility Pressure too high”
    “Charging pressure control: Switch-off as consequence”
    They couldn’t pinpoint the fault and ended up replacing spark-plugs and coils. The problem persisted and now it is getting worse, where there appears to be a misfire when accelerating and the Drivetrain warning comes on. These are the messages they see now:
    “Intake air temperature sensor, electrical: Short circuit to B+”
    “Charging pressure control, plausibility Pressure too high”
    “Charging pressure control: Switch-off as consequence”
    “Blow-off valve: Jammed closed”
    “Super-knocking, cylinder 6: Injection switch-off”
    Any ideas?
    Kind regards,
    Faizel

    Like

    • It looks like you have a couple of problems,,,,the charge pressure issue is probably caused by the electronic boost control valve it sit on the passenger side next to the valve cover,,,,it has 2 vacuum line going to it and a electrical plug,,,,also make sure the vacuum lines are ok,,,,,the knock on cylinder 6 and intake sensor sounds like new faults after they did the repairs,,,,,start with the electronic boost control valve and see what happens.

      Like

    • Make sure the intake sensor and cylinder 6 coil and injector are plugged in

      Like

    • Angel Guzman says:

      I have the same problem, did you find out what it was?

      Like

  2. Jamaal says:

    Hi there, I’m new to this page but would you be able to post a picture to show me where my turbo boost control valve is. I’m getting the drivetrain malfunction light and no boost.

    2012 f10 535i

    Like

    • Sorry I don’t have any pictures available ,,,it is located on the passengers side next to the valve cover,,,,,there should be a 2 vacuum hoses going to it and 1 electrical connector,,,1 of the vacuum hoses comes straight from the valve cover and straight to the valve.

      Like

  3. zulu95 says:

    BMW Technician, hope all is well with you and yours. I just used the blow off valve post to help cure lean codes in my wife’s 2013 X5 xDrive35i. Now we have another code showing up but no lights.

    Code: A736/not present JBE E9x activation

    SERVOTRONIC VALVE ACTIVATION

    PATH2: E7x ACTIVATION

    ECO VALVE ACTIVATION PATH 2
    I’m sure you have some idea of what all this means and can share your knowledge.
    TIA,
    Z

    Like

  4. zulu95 says:

    Thank you for getting back to me. Any other symptoms I should look out for as the engine has a two year warranty.
    Cheers,
    Z

    Like

  5. zulu95 says:

    Guess I’m answering my own question this time. Just got a 2DD6 Valvetronic code. Guess a new motor is required?

    Like

  6. zulu95 says:

    OK, I’ll start looking into having that taken care of ASAP!
    Thanks again,
    Z

    Like

  7. zulu95 says:

    Another unrelated question I’m sure you have an answer to: The steering column in my F15 adjusts in/out & up/down manually but not automatically. My Foxwell 530 shows two faults relating to position sensing problems. Easy fix or live without the auto function?

    Like

  8. zulu95 says:

    Thank you for your reply.
    Faults relate to Not Standardized and Count too high. I ran the Foxwell and Protool Standardization sections. Foxwell only retracted the wheel then nothing. Protool put the wheel through a full in/out and up/down then reported a failure.
    Not going to put $3K into a column unless it stops actually steering the car. Stupid fancy gadgets always get me in the end.
    Why are replacement motors not available?

    Like

  9. zulu95 says:

    Ah, lawyers. The Bard was correct.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.